XenForo 2 upgrade bug thread

Monsta_AU

...can I interest you in some vintage blades?
Staff member
Forum Administrator
Grand Society
Joined
Feb 2, 2011
Location
Guildford.nsw.au
XenForo 2 is now live and running. This is a complete overhaul to XF 1.5.x and runs entirely different code. All plugins and themes are not compatible with the new XF2 codebase so we can expect a heap of bugs and issues that may be coming up for some people.

We also have a new theme which has been applied and is in the DEFAULT state which means that colours, fonts, logos - everything needs to be adjusted to make it look better. There is no dark version of this theme at this time and this will not be added until the light version is closer to what we want to see.

If you run into any errors, possible bugs or issues or concerns then please post in this thread.
 
Last edited:

Monsta_AU

...can I interest you in some vintage blades?
Staff member
Forum Administrator
Grand Society
Joined
Feb 2, 2011
Location
Guildford.nsw.au
Tracker:
  1. Missing Avatars from userss Part fixed from backup - any Avatars uploaded post Sept 1 needs to be re-added by users
  2. Smileys appear to be lost (additional setup?) Fixed - reimported the smilies
  3. Home Page module width issues (raised with style/theme provider) Fixed - cheers Russ for your assistance!
  4. Prefixes need looking at for CSS weirdness (font sizing?)
  5. Server errors being logged Fixed, emoji feature related, updated DB tables to full Unicode utf8mb4 format
  6. Postbit needs widening 10-15px
  7. We really need a proper logo!!
  8. Update the colour scheme
  9. Adjust template layout options
  10. Re-implement width & defined width options previously removed troubleshooting (3)
  11. Footer adjustments & content
 
Last edited:

RustyBlade

Active Member
2018 Sabbatical
Joined
Feb 27, 2017
Location
Sydney
Great work. I'm sure there will be a few bugs but I and I'm sure others appreciate all the effort.
Here here @Monsta_AU
Definitely a legend!


Not a bug but truly prefer the old Page navigation at the bottom and top of the page. With actual page numbers to skip ahead or select a known page number than per Page navigation. So hated this on other forums as you can't easily skip ahead a few pages at a time either. :(
 
Last edited:

Monsta_AU

...can I interest you in some vintage blades?
Staff member
Forum Administrator
Grand Society
Joined
Feb 2, 2011
Location
Guildford.nsw.au
its different and I lost my mood ring so I’m not sure how I feel about it.
Cannot help on the mood ring, but yes it is different. I will get it a little more dialled in over the next few days. This thread is more about problems with the upgrade however, things now working, broken links or images etc.

Great work. I'm sure there will be a few bugs but I and I'm sure others appreciate all the effort.
Cheers. It will be a long-term thing and I need to get a number of things done to support it, but we will get there.

Whilst using an iPad mini in landscape mode, the home page looks a little distorted. See below.



But in portrait mode it seems ok:

So I made a modification for desktop, and I am seeing the same thing in a couple of places on the PC too. I may yet have to make some further changes.

I think it will do with the pixel width of the iPad. Can you go down the page to the charcoal section at the bottom, you should see the text for the theme changer, marked 'Paste&Cut Light XF2'. Right next to that is the width changer - see if bumping that helps?

Ok so tapping the page number then allows you to dial up any page. Me liking that (y)
Oh and the predictive text problem has gone away that I've noticed so far too. More thumbs up :angelic:(y)
It's all in testing stuff out. Most of the underlying code & modules have changed, so it is not that surprising that your issues with predictive text have cleared up. Most of the things that will affect those kinds of issues like the message editor is a third-party module or product which has of course been updated.
 

tim33z

Member
2018 Sabbatical Fail
Joined
Nov 30, 2017
Location
Melbourne
I think it will do with the pixel width of the iPad. Can you go down the page to the charcoal section at the bottom, you should see the text for the theme changer, marked 'Paste&Cut Light XF2'. Right next to that is the width changer - see if bumping that helps?
Whilst I don’t see the p&c light xf2 I see the width changer. Clicking this does not help the problem.

No biggy as I normally use the phone anyhoo but happy to test and report back where required.
 

alfredus

organises many group buys
State Convenor - SA
Group Buy Caporegime
Charity Auction Team
Joined
Nov 14, 2014
Location
Adelaide
Tracker:
  • Confirm Avatars from backups (likely anything after Sept 1 needs to be re-added by user)
  • Smileys appear to be lost (additional setup?)
  • Home Page module width issues
Thanks for the hard work - looks great (y)

Please don't forget the horns ;)

Also if possible please shorten the time between posting posts to 1sec - drives me always nuts...and it seems I cannot post here :( - it just didn't like the horns emoji...
 
Joined
Jun 23, 2017
Location
Richmond, New Zealand.
As per @todras comment. I use a PC and have the width problem.
Everything jammed into the left hand side with lots of empty space on the right.
The 'Change width' button very slightly alters the depth of the spaces, not the width.
Otherwise, looks nice and modern (and I'm sure we will get to like it).
 
Joined
Aug 26, 2018
Location
Australia
yep same here, width issue on PC W10 on both Chrome and IE browsers. Looks ok when screen is maximised (still everything is to the left though) but when you minimise and play with window size issue gets worse.. good luck with the bugs, looks nice
 
Top